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Reporting Services

For many years, SQL Server did not have a good answer for creating attractive
reports that summarize information in ways that make sense to business users.
Finally, Microsoft shipped SQL Server Reporting Services. Like Notification
Services, Reporting Services was originally an add-on for SQL Server 2000, and now
it’s a part of the core product. In this chapter, you'll learn how to use Reporting
Services to produce your own reports.

The Reporting Services Architecture

For a relatively new product, Reporting Services has a quite complex architecture.
The full Reporting Services architecture includes development tools, administration
tools, and report viewers. There are a number of ways to get to Reporting Services
programmatically, including SOAP and WMI interfaces.

Figure 18-1 shows a simplified diagram of the main Reporting Services components
that we’ll be using in this chapter.

Report Builder Report Designer

i L

Report Manager (> Report Server
Report Data
e Sources
Database

Figure 18-1: Report Server architecture

In this chapter you'll learn about these components:

e Report Server is the core engine that drives Reporting Services.

e Report Manager is a Web-based administrative interface for Reporting
Services.

e Report Designer is a developer tool for building complex reports.

e Report Builder is a simplified end-user tool for building reports.
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Using Report Designer

e The Report Server database stores report definitions. Reports themselves can
make use of data from many different data sources.

Using Report Designer

Reporting Services includes two tools for creating reports:

e Report Designer can create reports of any complexity that Reporting Services
supports, but requires you to understand the structure of your data and to be
able to navigate the Visual Studio user interface.

e Report Builder provides a simpler user interface for creating ad hoc reports,
directed primarily at business users rather than developers. Report Builder
requires a developer or administrator to set up a data model before end users
can create reports.

We'll start our tour of Reporting Services with Report Designer. Report Designer
runs inside the Business Intelligence Development Studio shell, and offers several
ways to create reports. You can either use the Report Wizard to quickly create a
report, or you can use a set of design tools to build a report from scratch. You can
also use the design tools to modify a report created with the wizard.

Using the Report Wizard

The easiest way to create a report in Report Designer is to use the Report Wizard.
Like all wizards, the Report Wizard walks you through the process in step-by-step
fashion. You can make the following choices in the wizard:

e The data source to use

e The query to use to retrieve data

e Whether to use a tabular or matrix layout for the report
e How to group the retrieved data

e What visual style to use

e Where to deploy the finished report

Try It!

To create a simple report using the Report Wizard, follow these steps:

1. Launch Business Intelligence Development Studio.
2. Select File » New » Project.

3. Select the Business Intelligence Projects project type.
4. Select the Report Server Project Wizard template.
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Reporting Services
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Name the new report ProductReportl and pick a convenient location to save it
in.

Click OK.

Read the first page of the Report Wizard and click Next.

Name the new data source AdventureWorksDS.

Click the Edit button.

Log on to your test server.

Select the AdventureWorks database.

Click OK.

Click the Credentials button.

Select Use Windows Authentication.

Click OK.

Check the Make This a Shared Data Source checkbox. This will make this
particular data source available to other Reporting Services applications in the
future.

Click Next.

Click the Query Builder button.

If the full query designer interface does not display by default, click the query
designer toolbar button at the far left end of the toolbar. Figure 18-2 shows the
tull query designer interface.
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Using Report Designer
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Figure 18-2: Query Builder

20. Click the Add Table toolbar button.

21. Select the Product table and click Add.

22. Click Close.

23. Check the Name, ProductNumber, Color, and ListPrice columns.

24. Click OK.

25. Click Next.

26. Select the Tabular layout and click Next.

27. Move the Color column to the Group area, and the other three columns to the
Detail area, as shown in Figure 18-3.
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Reporting Services
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Figurel8-3: Grouping columns in the report

4

28. Click Next.

29. Select the Stepped layout and click Next.

30. Select the Ocean style and click Next.

31. Accept the default deployment location and click Next.
32. Name the report ProductReportl.

33. Check the Preview Report checkbox.

34. Click Finish.

Figure 18-4 shows the finished report, open in Report Designer.
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Figure 18-4 shows the main features of Report Designer:

Figure 18-4: Report created by the Report Wizard

e The Datasets window shows the data that is available to the report.
e The main design window lets you view the report itself. You can see a
preview of the report, work with the report in a layout designer, or work with

the query that returns the data for the report.

e The Solution Explorer, Output, and Properties windows are the standard

Visual Studio windows.

Modifying a Report

Now that you've created a report with the Report Wizard, you can modify it with
the Report Designer. If you've used any sort of visual report design tool in the past,
you should have no problem making changes here. Among the possibilities here:
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Reporting Services

You can change the available data or the sort order for the report by
modifying the query on the Data tab.

You can resize or rearrange controls on the Layout tab.

You can use the Properties window to change properties of individual
controls including their font, alignment, colors, and so on.

Try It!

To modify the report that you just created, follow these steps:

1. Click the Data tab to view the query for the report.

2. Select a Descending sort type for the ListPrice column.

3. Click the Layout tab.

4. Click in the textbox at the top of the report, where the report name is displayed.

5. Use the Properties window to change the Value property of this control to
Products By Color.

6. Click on the header for the Product column.

7. Place the cursor between the Name and Product Number columns to display a
double-headed arrow. Hold down the mouse button and drag the cursor to the
right to widen the Name column.

8. Place the cursor between the Product Number and ListPrice columns to display
a double-headed arrow. Hold down the mouse button and drag the cursor to
the right to widen the Product Number column.

9. Click on the Preview tab to view the modified report, as shown in Figure 18-5.
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Using Report Designer
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Figure 18-5: Modified product report

Designing a Report From Scratch

You can also use Report Designer to build your own reports starting from scratch. In
general, you'll follow these steps to create a report:

1. Create a Report project in Business Intelligence Design Studio.
2. Associate one or more datasets with the report.

3. Create a query from the dataset.

4. Build the report layout.

Try It!

To create a fresh report in Report Designer, follow these steps:

1. Select File » Close Solution to close the existing report.
2. Select File » New » Project.

3. Select the Business Intelligence Projects project type.

4. Select the Report Server Project template.
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Name the new report ProductReport2 and pick a convenient location to save it
in.

Right-click on the Reports node in Solution Explorer and select Add » New
Item.

Select the Report template.

Name the new report ProductReport2.rdl and click Add.

Select the Data tab in the Report Designer.

. Click the Datasets dropdown and select <New Dataset> to open the Data

Source dialog box.

. Name the new Data Source AdventureWorksDS.
12.
13.
14.
15.
16.

Click the Edit button.

Connect to your test server and choose the AdventureWorks database.

Click OK.

Click OK again to create the data source.

Click the Query Designer toolbar button inside the Data tab to display the full
query designer user interface.

Click the Add Table button.

Select the Location table.

Click Add.

Click Close.

Check the boxes for the Name and CostRate columns.

Sort the dataset in ascending order by Name.

Click the Layout tab to show the blank report layout.

Hover your mouse over the toolbox tab to display the available controls for the
report.

Double-click the List control.

Expand the List control to the width of the report.

Expand the dataset in the Datasets window to show the column names.
Drag the Name and CostRate columns from the Datasets window and drop
them in the List control. Expand them horizontally until each takes up about
half of the List control. Figure 18-6 shows the report in layout view.
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Publishing a Report
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Figure 18-6: Designing a report from scratch

29. Select the Preview tab to see the report with data.

Publishing a Report

Creating reports in Business Intelligence Development Studio is good for
developers, but it doesn’t help users at all. In order for the reports you build to be
available to others, you must publish them to your Reporting Services server. To
publish a report, you can use the Build and Deploy menu items in Business
Intelligence Development Studio. Before you do this, you need to check the project’s
configuration to make sure that you've selected an appropriate server for the
deployment.

Try It!

To publish a report, follow these steps:
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Reporting Services

Close the ProductReport2 project.

Open the ProductReportl project.

Select Project » ProductReportl Properties.

Click the Configuration Manager button.

Set the Active Solution Configuration to Production.

Make sure the Configuration is set to Production and both the Build and
Deploy checkboxes are checked. Figure 18-7 shows the Configuration Manager.

Configuration Manager ﬂ E |

AN o

Ackive solukion configuration: Bckive solukion plakFarm:
IPru:u:qu:tiu:un j IDeFauIt j
Praoject contexts (check the project configurations b build or deplaw):
Praject | Canfiguration Flakfarm | BiLild | Deploy |
PraductRepart1 ‘Production. i 7] 7 bl

Close

Figure 18-7: Setting the active configuration

7. Click Close.

8. Fill in the URL for your Report Server. If you're developing on the same
computer where Reporting Services is installed, and you installed in the default
configuration, this will be http:/ /localhost/ReportServer. Figure 18-8 shows
the completed Property Pages.
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Publishing a Report
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Figure 18-8: Setting report project properties

9. Click OK.

10. Select Build » Deploy ProductReportl. The Output Window will track the
progress of BIDS in deploying your report, as shown in Figure 18-9. Depending
on the speed of your computer, building the report may take some time.

Qukpuk - 0 X
Show oukput From:  Build | | B | Sx =

Deploying report 'fProductBeportl/ProductBeportl’'. -
Deploy complete —- 0 errors, 0 warnings

========== Build: 1 succeeded or up-to-date, 0 failed, 0 skipped ========== _I
========== Deploy: 1 succeeded, 0 failed, 0 skipped ========== -
|

! _>I_I

Figure 18-9: Deploying a report

11. Launch SQL Server Management Studio.

12. Click the Connect button in Object Explorer and select Reporting Services.

13. Connect to your test server.

14. Expand the Home node in the Object Explorer tree to find the ProductReportl
project.

15. Expand the ProductReportl project to find the ProductReportl report.

16. Right-click on the report and select View Report.
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Reporting Services

17. If prompted, supply your username and password. The report will open in
your Web browser.

Using Report Builder

Report Designer gives you one way to create reports for Reporting Services, but it’s
not the only way. SQL Server 2005 also includes a tool directed at end users named
Report Builder. Unlike Report Designer, which is aimed at Developers, Report
Builder presents a simplified view of the report-building process and is intended for
business analysts and other end users.

Building a Data Model

Report Builder doesn’t let end users explore all of a SQL Server database. Instead, it
depends on a data model: a preselected group of tables and relationships that a
developer has identified as suitable for end-user reporting. To build a data model,
you use Business Intelligence Development Studio. Data models contain three
things:

e Data Sources connect the data model to actual data.
e Data Source Views draw data from data sources.
e Report Models contain entities that end users can use on reports.

Try It!

To create a data model, follow these steps:

1. If it’s not already open, launch Business Intelligence Development Studio

Select File » New » Project.

Select the Business Intelligence Projects project type.

Select the Report Model Project template.

Name the new project AWSales and save it in a convenient location.

Click OK.

Right-click on Data Sources in Solution Explorer and select Add New Data

Source.

Read the first page of the Add New Data Source Wizard and click Next.

9. Click New.

10. In the Connection Manager dialog box connect to the AdventureWorks
database on your test server and click OK.

11. Click Next.

12. Name the new data source AdventureWorks and click Finish.

NSO wN

@
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14.
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22.

23.
24.

Copyright © 2005 Accelebrate, Inc

Using Report Builder

Right-click on Data Source Views in Solution Explorer and select Add New
Data Source View.
Read the first page of the Add New Data Source View Wizard and click Next.
Select the AdventureWorks data source and click Next.
Select the Production.Product table and click the > button to move it to the
Included Objects listbox.
Select the Sales.SalesOrderDetail table and click the > button to move it to the
Included Objects listbox.

Click the Add Related Tables button.
Click Next.

Click Finish.

Right-click on Report Models in Solution Explorer and select Add New Report

Model.

Read the first page of the Report Model Wizard and click Next.
Select the Adventure Works data source view and click Next.
Keep the default rules selection, as shown in Figure 18-10, and click Next.
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Select the rules that contral how metadata will be generated from the data
sOUFCE,
_I Mame Descripkion Select all
¥ Create entities faor all tables Create an entity ... |
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¥ Create atkributes Create an attribu...
[T Create attributes For non-empty columns Create an attribo, .,
[¥ Create atkributes For auto-increment colurmns Create a hidden ...
[¥ Create date variations Create variations. ..
¥ Create numeric agoregates Create Sum, Avwg...
[¥ Create date aggregates Create First, Las. ..
¥ Createroles Create roles for ...
Select model language:
IEninsh (United Sktates) j
Help | < Back | Mext = I Einish ==| Cancel |
Y

Figure 18-10: Creating entities for end-user reporting
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Reporting Services

25. Choose the Update Statistics option and click Next.

26. Click Run to complete the wizard.

27. Click Finish. If you get a warning that a file was modified outside the source
editor, click Yes.

28. Select Build » Deploy AWSales to deploy the report model to the local
Reporting Services server.

Building a Report

Report Builder itself is a ClickOnce Windows Forms application. That means that
end users install it from the browser, but once installed it's not a browser-based
application. To get started with Report Builder, browse to your Reporting Services
home page. Typically, this will have a URL such as
http://ServerName/Reports (or http://1ocalhost/Reports if you're
running the browser on the same box with SQL Server 2005 itself). Figure 18-11
shows the Reporting Services home page.
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.
CiMew Folder < MNew Data Source 4] Upload File 5] Report Builder £ Show Details
3 Data Sources 'MEw [3 ProductReportl !'mMew

[ Models THew

[~
4

€l ’_ I_ ’_ I_ l_ %] Local intranet

Figure 18-11: Reporting Services home page

To install Report Builder, click the Report Builder link in the home page menu bar.
Report Builder will automatically load up all of the available report models and wait
for you to choose one to build a report from.
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Using Report Builder

Try It!

1. Open a browser window and navigate to http://localhost/Reports (or
to the appropriate Report Server URL if you're not working on the report
server).

2. Click the Report Builder link.

3. Depending on your operating system, you may have to confirm that you want
to run the application.

4. After Report Builder is installed, select the AdventureWorks report model and
the table report layout. Click OK. Figure 18-12 shows the new blank report that
Report Builder will create.
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Figure 18-12: New report in Report Builder
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Reporting Services

The Explorer window to the left of the design surface shows all of
the tables in the report model. Beneath that, the Fields window
shows the entities in the currently-selected table. Note that not
everything in this window is a column in the table: the report
model also contains aggregate entities such as Total Safety Stock
Level and automatically calculated fields.

5. Select the Product table.

6. Drag the Name field and drop it in the area labeled Drag and Drop Column
Fields.

7. Click on Special Offer Products in the Explorer window to show related child
tables.

8. Click on Sales Order Details.

9. Drag the Total Order Qty field and drop it to the right of the Name field.

10. Click where it says Click to Add Title and type Product Sales.

11. Click the Run Report button to produce the report shown in Figure 12-13.
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Using Report Builder
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Figure 18-13: Report in Report Builder

12. Click the Sort and Group toolbar button.

13. Select to sort by Total Order Qty descending.

14. Click OK.

15. Select File » Save.

16. Name the new report Product Sales.

17. Click Save. This will publish the report back to the Reporting Services server
that you originally downloaded Report Builder from.
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Reporting Services

Using Report Manager

The Web home page for Reporting Services provides a complete interface for
managing reports (as well as other objects such as data sources and models) after
they are created. This interface, known as Report Manager, is intended primarily for
database administrators, but as a developer you should know about its capabilities
for managing and modifying reports.

When you click on a report in Report Manager, you'll see the report’s data, as shown
in Figure 18-14.
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Figure 18-14: Report in Report Manager
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Using Report Manager

Note that reports in Report Manager open in a tabbed interface. The four tabs allow
you to perform various functions:

e View allows you to see the current data in the report.

e Properties lets you adjust such things as the report’s name, data source,
security credentials, caching, and end-user security.

e History shows you saved snapshots of the report.

e Subscriptions lets you create subscriptions to the report. Subscriptions allow
you to set up periodic delivery of reports to end users by e-mail or file share.
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Reporting Services

Exercises

Use Report Builder to create a report from the AdventureWorks data model
showing the minimum and maximum order quantity for orders taken by each
salesperson in the company. You'll find the necessary data in the SalesOrderHeader
and SalesOrderDetail tables.
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Solutions to Exercises

Solutions to Exercises

1. Open a browser window and navigate to http://localhost/Reports (or

to the appropriate Report Server URL if you're not working on the report

server).

Click the Report Builder link.

Select the AdventureWorks report model and the table report layout.

Click OK.

Select the Sales Order Header table.

Drag the Sales Person ID field and drop it in the area labeled Drag and Drop

Column Fields.

Click on Sales Order Details in the Explorer window.

8. Expand the Total Order Qty field in the Fields window to show the alternative
tields beneath it.

9. Drag the Min Order Qty field and drop it to the right of the Name field.

10. Drag the Max Order Qty field and drop it to the right of the Min Order Qty
field.

11. Click where it says Click to Add Title and type Sales Performance.

12. Click the Run Report button to produce the report shown in Figure 18-15.
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Reporting Services

& Report1 - Microsoft Report Builder M=l
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Figure 18-15: Sales performance report
Copyright © 2005 Accelebrate, Inc Introduction to SQL Server 2005 http://www.accelebrate.com

18-24



